Back to overview
Downtime
Platform is down
Apr 22, 2026 at 7:19am UTC
Affected services
my.delogue.com
Resolved
Apr 22, 2026 at 7:21am UTC
The incident has been resolved and services are operating normally again.
Affected services
Created
Apr 22, 2026 at 7:19am UTC
We’re aware of an issue, and we’re working to resolve it as quickly as possible. Please check the status page for updates
Affected services